Back to overview
Resolved

🚧 Services Temporarily Down for Server Repairs 🚧

Apr 19, 2026 at 3:47pm UTC
Affected services
Plex Media Server
Plex Request
Tautulli
Auth Service

Resolved
Apr 26, 2026 at 6:35am UTC

We're back up and running! All services have been restored and are performing normally.

Thank you for your patience! πŸ™

Updated
Apr 25, 2026 at 12:10am UTC

Some services have been restored and are now back online, but a few may still be working a bit slower or less reliably while we complete our checks. We’re continuing to monitor everything closely to make sure service is fully stable.

Created
Apr 19, 2026 at 3:47pm UTC

All Services will be offline for approximately 5-7 days starting April 19th, 2026 while I perform essential server repairs.

Expected return: April 23-27th, 2026. Thanks for your patience!